URI-1007 Solve

URI Online Judge | 1007

Difference

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
Read four integer values named A, B, C and D. Calculate and print the difference of product A and B by the product of C and D (A * B - C * D).

Input

The input file contains 4 integer values.

Output

Print DIFERENCA (DIFFERENCE in Portuguese) with all the capital letters, according to the following example, with a blank space before and after the equal signal.
Input SamplesOutput Samples
5
6
7
8
DIFERENCA = -26
0
0
7
8
DIFERENCA = -56
5
6
-7
8
DIFERENCA = 86
Problem link: https://www.urionlinejudge.com.br/judge/en/problems/view/1007

Solution:

  • [tab]
    • C
      • #include<stdio.h>
        int main(void){
            int a,b,c,d;
            long int result;
            while(scanf("%d%d%d%d",&a,&b,&c,&d)==4){
                result=(a*b)-(c*d);
                printf("DIFERENCA = %ld\n",result);
            }
            return 0;
        }
    • C++
      • #include <cstdio>
        int main()
        {
         int a;
         int b;
         int c;
         int d;
        
         scanf("%d", &a);
         scanf("%d", &b);
         scanf("%d", &c);
         scanf("%d", &d);
        
         printf("DIFERENCA = %d\n", a * b - c * d);
        
         return 0;
        }
3/Technology/post-list
Name

Codeforces,53,Problem Solve,90,Programming Tricks,1,URI,37,
ltr
item
DorHubs: URI-1007 Solve
URI-1007 Solve
https://resources.urionlinejudge.com.br/gallery/images/flags/br.gif
DorHubs
https://dorhubs.blogspot.com/2019/08/uri-1007-solve.html
https://dorhubs.blogspot.com/
https://dorhubs.blogspot.com/
https://dorhubs.blogspot.com/2019/08/uri-1007-solve.html
true
9087637800571592252
UTF-8
Loaded All Posts Not found any posts VIEW ALL Readmore Reply Cancel reply Delete By Home PAGES POSTS View All RECOMMENDED FOR YOU LABEL ARCHIVE SEARCH ALL POSTS Not found any post match with your request Back Home Sunday Monday Tuesday Wednesday Thursday Friday Saturday Sun Mon Tue Wed Thu Fri Sat January February March April May June July August September October November December Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec just now 1 minute ago $$1$$ minutes ago 1 hour ago $$1$$ hours ago Yesterday $$1$$ days ago $$1$$ weeks ago more than 5 weeks ago Followers Follow THIS PREMIUM CONTENT IS LOCKED STEP 1: Share to a social network STEP 2: Click the link on your social network Copy All Code Select All Code All codes were copied to your clipboard Can not copy the codes / texts, please press [CTRL]+[C] (or CMD+C with Mac) to copy