URI-1016 Solve

Distance

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
Two cars (X and Y) leave in the same direction. The car X leaves with a constant speed of 60 km/h and the car Y leaves with a constant speed of 90 km / h.
In one hour (60 minutes) the car Y can get a distance of 30 kilometers from the X car, in other words, it can get away one kilometer for each 2 minutes.
Read the distance (in km) and calculate how long it takes (in minutes) for the car Y to take this distance in relation to the other car.

Input

The input file contains 1 integer value.

Output

Print the necessary time followed by the message "minutos" that means minutes in Portuguese.
Input SampleOutput Sample
3060 minutos
110220 minutos
714 minutos
Problem link: https://www.urionlinejudge.com.br/judge/en/problems/view/1016

Solution:

  • [tab]
    • C
      • #include <stdio.h>
        
        
        int main()
        {
         int d;
        
         scanf("%d", &d);
        
         int t = d/((90 / 60.0) - (60 / 60.0));
        
         printf("%d minutos\n", t);
        
         return 0;
        }
    • C++
      • #include <iostream>
        
        using namespace std;
        
        int main()
        {
         int d;
        
         cin >> d;
        
         int t = d/((90 / 60.0) - (60 / 60.0));
         
         cout << t << " minutos" << endl;
        
         return 0;
        }
        
3/Technology/post-list
Name

Codeforces,53,Problem Solve,90,Programming Tricks,1,URI,37,
ltr
item
DorHubs: URI-1016 Solve
URI-1016 Solve
DorHubs
https://dorhubs.blogspot.com/2019/08/uri-1016-solve.html
https://dorhubs.blogspot.com/
https://dorhubs.blogspot.com/
https://dorhubs.blogspot.com/2019/08/uri-1016-solve.html
true
9087637800571592252
UTF-8
Loaded All Posts Not found any posts VIEW ALL Readmore Reply Cancel reply Delete By Home PAGES POSTS View All RECOMMENDED FOR YOU LABEL ARCHIVE SEARCH ALL POSTS Not found any post match with your request Back Home Sunday Monday Tuesday Wednesday Thursday Friday Saturday Sun Mon Tue Wed Thu Fri Sat January February March April May June July August September October November December Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec just now 1 minute ago $$1$$ minutes ago 1 hour ago $$1$$ hours ago Yesterday $$1$$ days ago $$1$$ weeks ago more than 5 weeks ago Followers Follow THIS PREMIUM CONTENT IS LOCKED STEP 1: Share to a social network STEP 2: Click the link on your social network Copy All Code Select All Code All codes were copied to your clipboard Can not copy the codes / texts, please press [CTRL]+[C] (or CMD+C with Mac) to copy