URI-1046 Solve

Game Time

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
Read the start time and end time of a game, in hours. Then calculate the duration of the game, knowing that the game can begin in a day and finish in another day, with a maximum duration of 24 hours. The message must be printed in portuguese “O JOGO DUROU X HORA(S)” that means “THE GAME LASTED X HOUR(S)”

Input

Two integer numbers representing the start and end time of a game.

Output

Print the duration of the game as in the sample output.
Input SampleOutput Sample
16 2O JOGO DUROU 10 HORA(S)
0 0O JOGO DUROU 24 HORA(S)
2 16O JOGO DUROU 14 HORA(S)
Problem link [URI 1046##link##]

Solution

  • [tab]
    • C
      • #include <stdio.h>
        
        int main()
        
        {
        
            int strtTm, endTm, durationTm;
        
            scanf("%d %d", &strtTm, &endTm);
        
            durationTm = endTm - strtTm;
        
            if (durationTm < 0)
        
            {
        
                durationTm = 24 + (endTm - strtTm);
        
            }
        
            if (strtTm == endTm)
        
            {
        
                printf("O JOGO DUROU 24 HORA(S)\n");
        
            }
        
            else printf("O JOGO DUROU %d HORA(S)\n", durationTm);
        
        
        
            return 0;
        
        }
    • C++
      • #include <iostream>
        
        using namespace std;
        
        int main()
        {
         int i, f;
         int ctr = 0;
        
         cin >> i >> f;
        
         if(i == f){
          cout << "O JOGO DUROU 24 HORA(S)" << endl;
          return 0;
         }
        
         while(i != f)
         {
          ctr++;
          i++;
          if(i == 25)
           i = 1;
         }
        
         cout << "O JOGO DUROU " << ctr <<  " HORA(S)" << endl;
        
         return 0;
        }
3/Technology/post-list
Name

Codeforces,53,Problem Solve,90,Programming Tricks,1,URI,37,
ltr
item
DorHubs: URI-1046 Solve
URI-1046 Solve
DorHubs
https://dorhubs.blogspot.com/2019/09/uri-1046-solve.html
https://dorhubs.blogspot.com/
https://dorhubs.blogspot.com/
https://dorhubs.blogspot.com/2019/09/uri-1046-solve.html
true
9087637800571592252
UTF-8
Loaded All Posts Not found any posts VIEW ALL Readmore Reply Cancel reply Delete By Home PAGES POSTS View All RECOMMENDED FOR YOU LABEL ARCHIVE SEARCH ALL POSTS Not found any post match with your request Back Home Sunday Monday Tuesday Wednesday Thursday Friday Saturday Sun Mon Tue Wed Thu Fri Sat January February March April May June July August September October November December Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec just now 1 minute ago $$1$$ minutes ago 1 hour ago $$1$$ hours ago Yesterday $$1$$ days ago $$1$$ weeks ago more than 5 weeks ago Followers Follow THIS PREMIUM CONTENT IS LOCKED STEP 1: Share to a social network STEP 2: Click the link on your social network Copy All Code Select All Code All codes were copied to your clipboard Can not copy the codes / texts, please press [CTRL]+[C] (or CMD+C with Mac) to copy