URI-1012 Solve

Area

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
Make a program that reads three floating point values: A, B and C. Then, calculate and show:
a) the area of the rectangled triangle that has base A and height C.
b) the area of the radius's circle C. (pi = 3.14159)
c) the area of the trapezium which has A and B by base, and C by height.
d) the area of ​​the square that has side B.
e) the area of the rectangle that has sides A and B.

Input

The input file contains three double values with one digit after the decimal point.

Output

The output file must contain 5 lines of data. Each line corresponds to one of the areas described above, always with a corresponding message (in Portuguese) and one space between the two points and the value. The value calculated must be presented with 3 digits after the decimal point.
Input SamplesOutput Samples
3.0 4.0 5.2TRIANGULO: 7.800
CIRCULO: 84.949
TRAPEZIO: 18.200
QUADRADO: 16.000
RETANGULO: 12.000
12.7 10.4 15.2TRIANGULO: 96.520
CIRCULO: 725.833
TRAPEZIO´: 175.560
QUADRADO: 108.160
RETANGULO: 132.080
Problem link: https://www.urionlinejudge.com.br/judge/en/problems/view/1012

Solution:

  • [tab]
    • C
      • #include<stdio.h>
        int main(void){
            double a,b,c,triangle,circle,trapezium,square,rectangle,PI=3.14159;
            scanf("%lf%lf%lf",&a,&b,&c);
            triangle=0.5*a*c;
            circle=PI*c*c;
            trapezium=(a+b)/2.0*c;
            square=b*b;
            rectangle=a*b;
            printf("TRIANGULO: %.3lf\n",triangle);
            printf("CIRCULO: %.3lf\n",circle);
            printf("TRAPEZIO: %.3lf\n",trapezium);
            printf("QUADRADO: %.3lf\n",square);
            printf("RETANGULO: %.3lf\n",rectangle);
            return 0;
        }
    • C++
      • #include <cstdio>
        
        int main()
        {
         double a;
         double b;
         double c;
        
         scanf("%lf", &a);
         scanf("%lf", &b);
         scanf("%lf", &c);
        
         printf("TRIANGULO: %.3lf\n", (a * c) / 2);
         printf("CIRCULO: %.3lf\n", c * c * 3.14159);
         printf("TRAPEZIO: %.3lf\n", ((a + b) / 2) * c);
         printf("QUADRADO: %.3lf\n", b * b);
         printf("RETANGULO: %.3lf\n", a * b);
        
         return 0;
        }
3/Technology/post-list
Name

Codeforces,53,Problem Solve,90,Programming Tricks,1,URI,37,
ltr
item
DorHubs: URI-1012 Solve
URI-1012 Solve
https://resources.urionlinejudge.com.br/gallery/images/flags/br.gif
DorHubs
https://dorhubs.blogspot.com/2019/08/uri-1012-solve.html
https://dorhubs.blogspot.com/
https://dorhubs.blogspot.com/
https://dorhubs.blogspot.com/2019/08/uri-1012-solve.html
true
9087637800571592252
UTF-8
Loaded All Posts Not found any posts VIEW ALL Readmore Reply Cancel reply Delete By Home PAGES POSTS View All RECOMMENDED FOR YOU LABEL ARCHIVE SEARCH ALL POSTS Not found any post match with your request Back Home Sunday Monday Tuesday Wednesday Thursday Friday Saturday Sun Mon Tue Wed Thu Fri Sat January February March April May June July August September October November December Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec just now 1 minute ago $$1$$ minutes ago 1 hour ago $$1$$ hours ago Yesterday $$1$$ days ago $$1$$ weeks ago more than 5 weeks ago Followers Follow THIS PREMIUM CONTENT IS LOCKED STEP 1: Share to a social network STEP 2: Click the link on your social network Copy All Code Select All Code All codes were copied to your clipboard Can not copy the codes / texts, please press [CTRL]+[C] (or CMD+C with Mac) to copy