URI-1014 Solve

Consumption

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
Calculate a car's average consumption being provided the total distance traveled (in Km) and the spent fuel total (in liters).

Input

The input file contains two values: one integer value representing the total distance (in Km) and the second one is a floating point number Y  representing the spent fuel total, with a digit after the decimal point.

Output

Present a value that represents the average consumption of a car with 3 digits after the decimal point, followed by the message "km/l".
Input SampleOutput Sample
500
35.0
14.286 km/l
2254
124.4
18.119 km/l
4554
464.6
9.802 km/l
Problem link: https://www.urionlinejudge.com.br/judge/en/problems/view/1014

Solution:

  • [tab]
    • C
      • #include <stdio.h>
        
        int main()
        {
         double a, b;
        
         scanf("%lf %lf", &a, &b);
        
         printf("%.3lf km/l\n", a / b);
        
         return 0;
        }
    • C++
      • #include <cstdio>
        
        int main()
        {
         double a;
         double b;
        
         scanf("%lf", &a);
         scanf("%lf", &b);
        
         printf("%.3lf km/l\n", a / b);
        
         return 0;
        }
        
3/Technology/post-list
Name

Codeforces,53,Problem Solve,90,Programming Tricks,1,URI,37,
ltr
item
DorHubs: URI-1014 Solve
URI-1014 Solve
DorHubs
https://dorhubs.blogspot.com/2019/08/uri-1014-solve.html
https://dorhubs.blogspot.com/
https://dorhubs.blogspot.com/
https://dorhubs.blogspot.com/2019/08/uri-1014-solve.html
true
9087637800571592252
UTF-8
Loaded All Posts Not found any posts VIEW ALL Readmore Reply Cancel reply Delete By Home PAGES POSTS View All RECOMMENDED FOR YOU LABEL ARCHIVE SEARCH ALL POSTS Not found any post match with your request Back Home Sunday Monday Tuesday Wednesday Thursday Friday Saturday Sun Mon Tue Wed Thu Fri Sat January February March April May June July August September October November December Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec just now 1 minute ago $$1$$ minutes ago 1 hour ago $$1$$ hours ago Yesterday $$1$$ days ago $$1$$ weeks ago more than 5 weeks ago Followers Follow THIS PREMIUM CONTENT IS LOCKED STEP 1: Share to a social network STEP 2: Click the link on your social network Copy All Code Select All Code All codes were copied to your clipboard Can not copy the codes / texts, please press [CTRL]+[C] (or CMD+C with Mac) to copy