URI-1040 Solve

Average 3

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
Read four numbers (N1, N2, N3, N4), which one with 1 digit after the decimal point, corresponding to 4 scores obtained by a student. Calculate the average with weights 2, 3, 4 e 1 respectively, for these 4 scores and print the message "Media: " (Average), followed by the calculated result. If the average was 7.0 or more, print the message "Aluno aprovado." (Approved Student). If the average was less than 5.0, print the message: "Aluno reprovado."(Reproved Student). If the average was between 5.0 and 6.9, including these, the program must print the message "Aluno em exame." (In exam student).
In case of exam, read one more score. Print the message "Nota do exame: " (Exam score) followed by the typed score. Recalculate the average (sum the exam score with the previous calculated average and divide by 2) and print the message “Aluno aprovado.” (Approved student) in case of average 5.0 or more) or "Aluno reprovado."(Reproved student) in case of average 4.9 or less. For these 2 cases (approved or reproved after the exam) print the message "Media final: " (Final average) followed by the final average for this student in the last line.

Input

The input contains four floating point numbers that represent the students' grades.

Output

Print all the answers with one digit after the decimal point.
Input SampleOutput Sample
2.0 4.0 7.5 8.0
6.4
Media: 5.4
Aluno em exame.
Nota do exame: 6.4
Aluno aprovado.
Media final: 5.9
2.0 6.5 4.0 9.0Media: 4.8
Aluno reprovado.
9.0 4.0 8.5 9.0Media: 7.3
Aluno aprovado.

Problem link: https://www.urionlinejudge.com.br/judge/en/problems/view/1040

Solution:

  • [tab]
    • C
      • #include <stdio.h>
        int main()
        {
            double a, b, c, d, last, m;
            scanf("%lf %lf %lf %lf", &a, &b, &c, &d);
            m = (a * 2 + b * 3 + c * 4 + d) / 10;
            printf("Media: %.1f\n", m);
            if (m >= 7.0){
                printf("Aluno aprovado.\n");
            }
            else if (m >= 5.0)
            {
                printf("Aluno em exame.\n");
                scanf("%lf", &last);
                printf("Nota do exame: %.1f\n", last);
                if (last + m / 2.0 > 5.0){
                    printf("Aluno aprovado.\n");
                }
                else{
                    printf("Aluno reprovado.\n");
                }
                printf("Media final: %.1f\n", (last + m ) / 2.0);
            }
            else{
                printf("Aluno reprovado.\n");
            }
            return 0;
        }
        
    • C++
      • #include <cstdio>
        
        #define SC1(a) scanf("%f", &a)
        #define SC4(a, b, c, d) scanf("%f %f %f %f", &a, &b, &c, &d)
        
        using namespace std;
        
        int main(int argc, char const *argv[])
        {
         float a, b, c, d, m, f;
        
         SC4(a, b, c, d);
         a = (a * 20)/100;
         b = (b * 30)/100;
         c = (c * 40)/100;
         d = (d * 10)/100;
         m = a + b + c + d;
        
         if(m >= 7.0){
          printf("Media: %.1f\nAluno aprovado.\n", m);
         }else if(m < 5.0){
          printf("Media: %.1f\nAluno reprovado.\n", m);
         }else{
          SC1(f);
          printf("Media: %.1f\nAluno em exame.\nNota do exame: %.1f\n", m, f);
          if ((m + f) / 2 < 5.0) printf("Aluno reprovado.\nMedia final: %.1f\n", (m + f) / 2);
          else printf("Aluno aprovado.\nMedia final: %.1f\n", (m + f) / 2);
         }
        
         return 0;
        }
3/Technology/post-list
Name

Codeforces,53,Problem Solve,90,Programming Tricks,1,URI,37,
ltr
item
DorHubs: URI-1040 Solve
URI-1040 Solve
DorHubs
https://dorhubs.blogspot.com/2019/08/uri-1040-solve.html
https://dorhubs.blogspot.com/
https://dorhubs.blogspot.com/
https://dorhubs.blogspot.com/2019/08/uri-1040-solve.html
true
9087637800571592252
UTF-8
Loaded All Posts Not found any posts VIEW ALL Readmore Reply Cancel reply Delete By Home PAGES POSTS View All RECOMMENDED FOR YOU LABEL ARCHIVE SEARCH ALL POSTS Not found any post match with your request Back Home Sunday Monday Tuesday Wednesday Thursday Friday Saturday Sun Mon Tue Wed Thu Fri Sat January February March April May June July August September October November December Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec just now 1 minute ago $$1$$ minutes ago 1 hour ago $$1$$ hours ago Yesterday $$1$$ days ago $$1$$ weeks ago more than 5 weeks ago Followers Follow THIS PREMIUM CONTENT IS LOCKED STEP 1: Share to a social network STEP 2: Click the link on your social network Copy All Code Select All Code All codes were copied to your clipboard Can not copy the codes / texts, please press [CTRL]+[C] (or CMD+C with Mac) to copy