URI-1043 Solve

Triangle

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
Read three point floating values (A, B and C) and verify if is possible to make a triangle with them. If it is possible, calculate the perimeter of the triangle and print the message:

Perimetro = XX.X

If it is not possible, calculate the area of the trapezium which basis A and B and C as height, and print the message:

Area = XX.X

Input

The input file has tree floating point numbers.

Output

Print the result with one digit after the decimal point.
Input SampleOutput Sample
6.0 4.0 2.0Area = 10.0
6.0 4.0 2.1Perimetro = 12.1
Problem link: [URI-1043##link##]

Solution

  • [tab]
    • C
      • #include<stdio.h>
        int main()
        {
            float A, B, C, areaTraphisium, perimeterTriangle ;
        
            scanf("%f %f %f", &A, &B, &C);
        
            if ((A < (float)(B+C)) && (B < (float)(A+C)) && (C < (float)(B+A)))
            {
                perimeterTriangle = A + B + C;
                printf("Perimetro = %.1f\n",perimeterTriangle);
        
        
            }
            else
            {
                areaTraphisium = ((A + B) * C) / 2;
                printf("Area = %.1f\n",areaTraphisium);
            }
            return 0;
        }
    • C++
      • #include <iostream>
        #include <iomanip>
        
        using namespace std;
        
        int main()
        {
         float a, b, c;
         bool ver = false;
        
         cin >> a >> b >> c;
        
         float mod = b - c;
         if(mod < 0)
          mod = -mod;
        
         if(mod < a && a < (b + c)){
          cout << "Perimetro = " << fixed << setprecision(1) << (a + b + c) << endl; 
         }else{
          cout << "Area = " << fixed << setprecision(1) << ((a + b) * c) / 2 << endl; 
         }
        
         return 0;
        }
3/Technology/post-list
Name

Codeforces,53,Problem Solve,90,Programming Tricks,1,URI,37,
ltr
item
DorHubs: URI-1043 Solve
URI-1043 Solve
DorHubs
https://dorhubs.blogspot.com/2019/09/uri-1043-solve.html
https://dorhubs.blogspot.com/
https://dorhubs.blogspot.com/
https://dorhubs.blogspot.com/2019/09/uri-1043-solve.html
true
9087637800571592252
UTF-8
Loaded All Posts Not found any posts VIEW ALL Readmore Reply Cancel reply Delete By Home PAGES POSTS View All RECOMMENDED FOR YOU LABEL ARCHIVE SEARCH ALL POSTS Not found any post match with your request Back Home Sunday Monday Tuesday Wednesday Thursday Friday Saturday Sun Mon Tue Wed Thu Fri Sat January February March April May June July August September October November December Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec just now 1 minute ago $$1$$ minutes ago 1 hour ago $$1$$ hours ago Yesterday $$1$$ days ago $$1$$ weeks ago more than 5 weeks ago Followers Follow THIS PREMIUM CONTENT IS LOCKED STEP 1: Share to a social network STEP 2: Click the link on your social network Copy All Code Select All Code All codes were copied to your clipboard Can not copy the codes / texts, please press [CTRL]+[C] (or CMD+C with Mac) to copy