URI-1019 Solve

Time Conversion

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
Read an integer value, which is the duration in seconds of a certain event in a factory, and inform it expressed in hours:minutes:seconds.

Input

The input file contains an integer N.

Output

Print the read time in the input file (seconds) converted in hours:minutes:seconds like the following example.
Input SampleOutput Sample
5560:9:16
10:0:1
14015338:55:53
Problem link: https://www.urionlinejudge.com.br/judge/en/problems/view/1019

Solution:

  • [tab]
    • C
      • #include<stdio.h>
        int main(){
           int h, m, s, n;
           scanf("%d", &n);
         
           h = n / 3600;
           m = n % 3600 / 60;
           s = n % 60;
           printf("%d:%d:%d\n", h, m, s);
           return 0;
        }
    • C++
      • #include <iostream>
        
        using namespace std;
        
        int main()
        {
         int t;
        
         cin >> t;
        
         int h = t / 3600;
         t = t - (h * 3600);
        
         int m = t / 60;
         t = t - (m * 60);
        
         cout << h << ":" << m << ":" << t << endl;
        
         return 0;
        }
3/Technology/post-list
Name

Codeforces,53,Problem Solve,90,Programming Tricks,1,URI,37,
ltr
item
DorHubs: URI-1019 Solve
URI-1019 Solve
DorHubs
https://dorhubs.blogspot.com/2019/08/uri-1019-solve.html
https://dorhubs.blogspot.com/
https://dorhubs.blogspot.com/
https://dorhubs.blogspot.com/2019/08/uri-1019-solve.html
true
9087637800571592252
UTF-8
Loaded All Posts Not found any posts VIEW ALL Readmore Reply Cancel reply Delete By Home PAGES POSTS View All RECOMMENDED FOR YOU LABEL ARCHIVE SEARCH ALL POSTS Not found any post match with your request Back Home Sunday Monday Tuesday Wednesday Thursday Friday Saturday Sun Mon Tue Wed Thu Fri Sat January February March April May June July August September October November December Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec just now 1 minute ago $$1$$ minutes ago 1 hour ago $$1$$ hours ago Yesterday $$1$$ days ago $$1$$ weeks ago more than 5 weeks ago Followers Follow THIS PREMIUM CONTENT IS LOCKED STEP 1: Share to a social network STEP 2: Click the link on your social network Copy All Code Select All Code All codes were copied to your clipboard Can not copy the codes / texts, please press [CTRL]+[C] (or CMD+C with Mac) to copy